Windows Vista Security Pains!

August 4, 2006

I have recently installed Windows Vista Beta 2 and started playing around with it. First impressions are good….although as a developer the security features like UAC are pretty in your face (probably good for end users). I immediately disabled that by editing the local system policy by running:

 secpol.msc ->  Local Policies -> Security Options -> Disable the policy “User Account Control: Run all administrators in Admin Approval Mode”

That definitely made those annoying messages go away! I had to install Visual Studio 2005 and I was thinking of playing with Atlas. Once I got that installed and tried to create a sample website Visual Studio was barking back at me saying: 

Error HRESULT E_FAIL has been returned from a call to a COM component

Now what? Well supposedly vista will not start application in admin mode even if you are logged in as an administrator.  The fix: Right click on the shortcut to studio and click Run as Administrator and it works like a charm.

Here is a link to Microsoft KB which shows how to configure specific applications to always run as admin.

-Nikhil

Advertisements

One Response to “Windows Vista Security Pains!”

  1. Supriya Says:

    I tried what you said to do in your blog, but I can’t seem to make those annoying messages go away… I asked around for a lot of help, but no one else could do it either… You must be some sort of Guru in the world of developers…


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: